fix(deps): bump undici 7.x to >=7.29.1 (CVE-2026-85024)

Raises the undici 7.x override floor in mem0-ts, openclaw and pi-agent-plugin; resolves to 7.30.0.

Fixes: https://app.vanta.com/c/mem0.ai/tests/packages-checked-for-vulnerabilities-v2-records-closed-github-dependabot-medium

Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
This commit is contained in:
harshgupta-mem0
2026-09-30 15:26:05 +05:30
co-authored by Claude Opus 5.5
parent 94c3fe9f23
commit 659df4b07b
9 changed files with 23 additions and 23 deletions
+7 -7
View File
@@ -27,7 +27,7 @@ overrides:
glob@>=10.2.0 <10.5.0: ^10.5.0
'@modelcontextprotocol/sdk': ^1.25.4
esbuild: '>=0.28.1'
undici@<7.29.0: '>=7.29.0 <8.0.0'
undici@<7.29.1: '>=7.29.1 <8.0.0'
'@aws-sdk/client-bedrock-runtime': 3.967.0
'@aws-sdk/client-neptune-graph': 3.966.0
axios@<1.18.0: '>=1.18.0 <2.0.0'
@@ -4609,8 +4609,8 @@ packages:
undici-types@7.24.6:
resolution: {integrity: sha512-WRNW+sJgj5OBN4/0JpHFqtqzhpbnV0GuB+OozA9gCL7a993SmU+1JBZCzLNxYsbMfIeDL+lTsphD5jN5N+n0zg==}
undici@7.29.0:
resolution: {integrity: sha512-IDxfleLmmbSskfWSUATiN1nfn2rDuvnMOqb5CWR92iIfojA0Ud+ulOAAEQ57LPr9rWmsreUyf5lwyao+7GNNVw==}
undici@7.30.0:
resolution: {integrity: sha512-dkrQXeHSaoamnItlYbmzG0wFYrM0ZwDxCIg0A7aKjTyyhh9svRzCNFEzV+Vm05/yehjCzjDZ31KXfGEjYSztDQ==}
engines: {node: '>=20.18.1'}
update-browserslist-db@1.3.2:
@@ -6138,7 +6138,7 @@ snapshots:
ms: 2.1.3
secure-json-parse: 4.1.0
tslib: 2.8.1
undici: 7.29.0
undici: 7.30.0
transitivePeerDependencies:
- supports-color
@@ -6706,7 +6706,7 @@ snapshots:
dependencies:
'@qdrant/openapi-typescript-fetch': 1.2.6
typescript: 5.5.4
undici: 7.29.0
undici: 7.30.0
'@qdrant/openapi-typescript-fetch@1.2.6': {}
@@ -7178,7 +7178,7 @@ snapshots:
'@turbopuffer/turbopuffer@2.5.0':
dependencies:
pako: 2.2.0
undici: 7.29.0
undici: 7.30.0
'@types/babel__core@7.20.5':
dependencies:
@@ -10182,7 +10182,7 @@ snapshots:
undici-types@7.24.6: {}
undici@7.29.0: {}
undici@7.30.0: {}
update-browserslist-db@1.3.2(browserslist@4.28.9):
dependencies: